Jump to content

Windows 7 File Sharing with Mac OS X

+ 2
  lwm's Photo
Posted Nov 03 2009 09:29 AM

If you want to share your Windows 7 files with Mac OS X users, use the SMB (Server Message Block) protocol in Mac OS X.

The following steps outline how you can view shared folders in Mac OS X:

  1. In Finder, select Go→Connect to Server....

  2. Specify the “smb://” prefix, followed by the IP address (or computer name) of the Windows 7 computer and the “:139” port number. Click Connect.

  3. If the connection is successful, you will be asked to log in to the Windows 7 computer. For sharing with everyone, select the Guest account and click Connect.

  4. You will be asked to select the folder to mount in Mac OS X (see Figure 3.15). Select the folder and click OK.

  5. Finally, the shared folder is now available in Mac OS X.

Figure 3.15. Selecting the shared folder to mount

Attached Image

Windows 7: Up and Running

Learn more about this topic from Windows 7: Up and Running.

This compact book offers the quickest path for Windows XP and Vista users to get started with Microsoft's Windows 7 operating system. With Windows 7: Up and Running, you get the essential information you need to upgrade or install the system and configure it to fit your activities, along with a tour of Windows 7's features and built-in applications. Windows 7 is poised to be a big hit among PC users, and with this handy guide, you can be productive with it right away.

See what you'll learn

0 Subscribe

2 Replies

  ziki's Photo
Posted Feb 04 2011 05:10 AM

Iwm, thank you very much for this post. The ":139" port wasn't even required after all for me to connect from Snow Leopard to Win 7, but I had different problem: the password.

Everybody please keep in mind, that the password is required to be set on the Win 7 PC. Otherwise the network connection wont work! I obviously had admin password off on my PC at home, but after seting it up i finaly connected after following Iwm's steps.
  thomaskeller1's Photo
Posted Oct 18 2012 03:36 PM

No mountable volumes show up, though I was able to log in. There must be something else that need to be done on the windows side besides setting the folder (on the windows machine) for sharing.